$re = '/^(?:(\d{1,3}\.?(?:\d{1,3}\.?)*)?) ?([^\W\d]+)/m';
$str = 'section
1 section
2. section
2.1 subsection
2.1.1 subsection
2.1.1. subsection
1111
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);