re = /^(?:(\d{1,3}\.?(?:\d{1,3}\.?)*)?) ?([^\W\d]+)/m
str = 'section
1 section
2. section
2.1 subsection
2.1.1 subsection
2.1.1. subsection
1111
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end