// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:(\d{1,3}\.?(?:\d{1,3}\.?)*)?) ?([^\W\d]+)").unwrap();
let string = "section
1 section
2. section
2.1 subsection
2.1.1 subsection
2.1.1. subsection
1111
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}