#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "((?<!\+)[a-zA-Z]+)|([a-zA-Z]+(?!\+))"
Local $sString = "" & @CRLF & _
"1q+1q+1" & @CRLF & _
"1+q+1+q+1" & @CRLF & _
"q+a+123" & @CRLF & _
"123+a+q" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")