import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?<!\\+)[a-zA-Z]+)|([a-zA-Z]+(?!\\+))";
final String string = "\n"
+ "1q+1q+1\n"
+ "1+q+1+q+1\n"
+ "q+a+123\n"
+ "123+a+q\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}