re = /((?<!\+)[a-zA-Z]+)|([a-zA-Z]+(?!\+))/
str = '
1q+1q+1
1+q+1+q+1
q+a+123
123+a+q
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end