package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.+?)([0-9]+)`)
var str = `Hubert 208 apt 1
Mass Av 300, block 3
Hubert 1 apt 1
Mass Av 3 block 3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}