$re = '/^(.+?)([0-9]+)/m';
$str = 'Hubert 208 apt 1
Mass Av 300, block 3
Hubert 1 apt 1
Mass Av 3 block 3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);