re = /^(.+?)([0-9]+)/m
str = 'Hubert 208 apt 1
Mass Av 300, block 3
Hubert 1 apt 1
Mass Av 3 block 3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end