// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(.+?)([0-9]+)").unwrap();
let string = "Hubert 208 apt 1
Mass Av 300, block 3
Hubert 1 apt 1
Mass Av 3 block 3";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}