import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(?<!\")(?:\"\")*\"[^\"]*(?:\"\"[^\"]*)*\"|\\w+!)(*SKIP)(*F)|\\b[A-Z]+\\K\\d+\\b";
final String string = "SI(F5=\"\";\"\";\"Z_PACK_TYPE\")\n"
+ "MARKET!A5\n"
+ "MARKET!MQ5\n"
+ "MARKET!AB5\n"
+ "MARKET!TX5\n"
+ "MARKET!SX5\n"
+ "MATMAS05!CZ5=\"3200\";MARKET!DA5\n"
+ "SI(MATMAS05!CZ5=\"3200\";MATMAS05!CZ5=\"3200\";MARKET!DA5;\"\")\n"
+ "SI(L5=\"\";\"\";\"STRING\")\n"
+ "SI(MATMAS05!CZ5=\"3300\";MARKET!DA5;\"\"\n"
+ "SI(ESTVIDE(MARKET!EG5);\"\";SI(MATMAS05!CZ5=\"3200\";MARKET!EG5;\"\")";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}