#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([78]\d{10}|1\d{9}|0\d{6}[78]\d{10}|0\d{7}1\d{9})$"
Local $sString = "85556987456" & @CRLF & _
"75556987456" & @CRLF & _
"1555698745" & @CRLF & _
"000000085556987456" & @CRLF & _
"000000075556987456" & @CRLF & _
"000000001556987456" & @CRLF & _
"123091" & @CRLF & _
"981279381273" & @CRLF & _
"098" & @CRLF & _
"asdasd" & @CRLF & _
"0123901023910293010293" & @CRLF & _
"00000000000000"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")