re = /^([78]\d{10}|1\d{9}|0\d{6}[78]\d{10}|0\d{7}1\d{9})$/m
str = '85556987456
75556987456
1555698745
000000085556987456
000000075556987456
000000001556987456
123091
981279381273
098
asdasd
0123901023910293010293
00000000000000'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end