// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([78]\d{10}|1\d{9}|0\d{6}[78]\d{10}|0\d{7}1\d{9})$").unwrap();
let string = "85556987456
75556987456
1555698745
000000085556987456
000000075556987456
000000001556987456
123091
981279381273
098
asdasd
0123901023910293010293
00000000000000";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}