import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([78]\\d{10}|1\\d{9}|0\\d{6}[78]\\d{10}|0\\d{7}1\\d{9})$";
final String string = "85556987456\n"
+ "75556987456\n"
+ "1555698745\n"
+ "000000085556987456\n"
+ "000000075556987456\n"
+ "000000001556987456\n"
+ "123091\n"
+ "981279381273\n"
+ "098\n"
+ "asdasd\n"
+ "0123901023910293010293\n"
+ "00000000000000";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}