# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?m)(^|(?<=,))\s+|\s+($|(?=,))//gm;t' <<< "SpacesOnLeft,SpacesOnRight,SpacesLeftAndRight,Normal
1,1 , 1 ,1
2,2 , 2 ,2
red clover,red clover , red clover ,red clover"