re = /(?m)(^|(?<=,))\s+|\s+($|(?=,))/m
str = 'SpacesOnLeft,SpacesOnRight,SpacesLeftAndRight,Normal
1,1 , 1 ,1
2,2 , 2 ,2
red clover,red clover , red clover ,red clover'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result