$re = '/(?m)(^|(?<=,))\s+|\s+($|(?=,))/m';
$str = 'SpacesOnLeft,SpacesOnRight,SpacesLeftAndRight,Normal
1,1 , 1 ,1
2,2 , 2 ,2
red clover,red clover , red clover ,red clover';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;