import Foundation
let pattern = #"(?m)(^|(?<=,))\s+|\s+($|(?=,))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
SpacesOnLeft,SpacesOnRight,SpacesLeftAndRight,Normal
1,1 , 1 ,1
2,2 , 2 ,2
red clover,red clover , red clover ,red clover
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)