#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\S+mp3\S+"
Local $sString = "song1 (mp3world.com)" & @CRLF & _
"song2 mymp3.net" & @CRLF & _
"song3 foo [mp3info.com]" & @CRLF & _
""mp3selection" song4" & @CRLF & _
"ourmp3world song4 bar" & @CRLF & _
"is mp3 dr"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")