// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\S+mp3\S+").unwrap();
let string = "song1 (mp3world.com)
song2 mymp3.net
song3 foo [mp3info.com]
\"mp3selection\" song4
ourmp3world song4 bar
is mp3 dr";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}