import re
regex = re.compile(r"\S+mp3\S+", flags=re.MULTILINE)
test_str = ("song1 (mp3world.com)\n"
"song2 mymp3.net\n"
"song3 foo [mp3info.com]\n"
"\"mp3selection\" song4\n"
"ourmp3world song4 bar\n"
"is mp3 dr")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")