$re = '/\S+mp3\S+/m';
$str = 'song1 (mp3world.com)
song2 mymp3.net
song3 foo [mp3info.com]
"mp3selection" song4
ourmp3world song4 bar
is mp3 dr';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);