import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([2-9]\\d{2})(?!1)(?<!1)";
final String string = "123\n"
+ "456\n"
+ "789\n"
+ "211\n"
+ "333\n"
+ "111\n"
+ "222\n"
+ "411\n"
+ "511\n"
+ "123456789\n"
+ "1234-1234-12345\n"
+ "555-444-333\n"
+ "555-411-311\n\n"
+ "These would be valid area codes: 414, 608, 920, 319, 715\n"
+ "These would NOT be valid: 023, 123, 411, 611, 811, 911";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}