use strict;
my $str = '123
456
789
211
333
111
222
411
511
123456789
1234-1234-12345
555-444-333
555-411-311
These would be valid area codes: 414, 608, 920, 319, 715
These would NOT be valid: 023, 123, 411, 611, 811, 911';
my $regex = qr/([2-9]\d{2})(?!1)(?<!1)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}