$re = '/([2-9]\d{2})(?!1)(?<!1)/m';
$str = '123
456
789
211
333
111
222
411
511
123456789
1234-1234-12345
555-444-333
555-411-311
These would be valid area codes: 414, 608, 920, 319, 715
These would NOT be valid: 023, 123, 411, 611, 811, 911';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);