const regex = /([2-9]\d{2})(?!1)(?<!1)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([2-9]\\d{2})(?!1)(?<!1)', 'gm')
const str = `123
456
789
211
333
111
222
411
511
123456789
1234-1234-12345
555-444-333
555-411-311
These would be valid area codes: 414, 608, 920, 319, 715
These would NOT be valid: 023, 123, 411, 611, 811, 911`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}