using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:title\s*:?\s*)([\w\s]+?)\s+(?=author)";
string input = @"strings = [
'title : Booking things author J smith',
'title : Unbe God author: K. sweet'
]";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}