const regex = new RegExp('(?:title\\s*:?\\s*)([\\w\\s]+?)\\s+(?=author)', 'gi')
const str = `strings = [
'title : Booking things author J smith',
'title : Unbe God author: K. sweet'
]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}