$re = '/(?:title\s*:?\s*)([\w\s]+?)\s+(?=author)/i';
$str = 'strings = [
\'title : Booking things author J smith\',
\'title : Unbe God author: K. sweet\'
]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);