re = /(?:title\s*:?\s*)([\w\s]+?)\s+(?=author)/i
str = 'strings = [
\'title : Booking things author J smith\',
\'title : Unbe God author: K. sweet\'
]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end