#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^ *person *(?<person>.*?) *\| *age *(?<age>.*?) *\| *(?<someMarker>.*?) *\|gender *(?<gender>.*)$"
Local $sString = "person1 | Age 20 | M |Gender Male" & @CRLF & _
"person2 | Age 11 | |Gender Female" & @CRLF & _
"person3 | Age 23 | M |Gender Female" & @CRLF & _
"person4 | Age 32 | |Gender Male" & @CRLF & _
"person5 | Age 41 | M |Gender Male" & @CRLF & _
"person11| Age 28 | M |Gender Female" & @CRLF & _
"person12| Age 31 | M |Gender Male" & @CRLF & _
"person10| Age 33 | |Gender Male" & @CRLF & _
"person8 | Age 26 | |Gender Male"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")