import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^ *person *(?<person>.*?) *\\| *age *(?<age>.*?) *\\| *(?<someMarker>.*?) *\\|gender *(?<gender>.*)$";
final String string = "person1 | Age 20 | M |Gender Male\n"
+ "person2 | Age 11 | |Gender Female\n"
+ "person3 | Age 23 | M |Gender Female\n"
+ "person4 | Age 32 | |Gender Male\n"
+ "person5 | Age 41 | M |Gender Male\n"
+ "person11| Age 28 | M |Gender Female\n"
+ "person12| Age 31 | M |Gender Male\n"
+ "person10| Age 33 | |Gender Male\n"
+ "person8 | Age 26 | |Gender Male";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}