$re = '/^ *person *(?<person>.*?) *\| *age *(?<age>.*?) *\| *(?<someMarker>.*?) *\|gender *(?<gender>.*)$/im';
$str = 'person1 | Age 20 | M |Gender Male
person2 | Age 11 | |Gender Female
person3 | Age 23 | M |Gender Female
person4 | Age 32 | |Gender Male
person5 | Age 41 | M |Gender Male
person11| Age 28 | M |Gender Female
person12| Age 31 | M |Gender Male
person10| Age 33 | |Gender Male
person8 | Age 26 | |Gender Male';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);