# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^ *person *(?<person>.*?) *\| *age *(?<age>.*?) *\| *(?<someMarker>.*?) *\|gender *(?<gender>.*)$"
test_str = ("person1 | Age 20 | M |Gender Male\n"
"person2 | Age 11 | |Gender Female\n"
"person3 | Age 23 | M |Gender Female\n"
"person4 | Age 32 | |Gender Male\n"
"person5 | Age 41 | M |Gender Male\n"
"person11| Age 28 | M |Gender Female\n"
"person12| Age 31 | M |Gender Male\n"
"person10| Age 33 | |Gender Male\n"
"person8 | Age 26 | |Gender Male")
matches = re.finditer(regex, test_str, re.IGNORECASE | re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.