#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)data-event-title=\"([^*]+).*class=\"odds\">([^<]+)"
Local $sString = "data-event-title="Yuichi Sugita* vs Adrian Mannarino">" & @CRLF & _
" <span class="odds-container">" & @CRLF & _
" <b class="odds">1/12</b>" & @CRLF & _
" </a>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")