using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"data-event-title=\""([^*]+).*class=\""odds\"">([^<]+)";
string input = @"data-event-title=""Yuichi Sugita* vs Adrian Mannarino"">
<span class=""odds-container"">
<b class=""odds"">1/12</b>
</a>";
RegexOptions options = RegexOptions.Singleline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}