package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)data-event-title=\"([^*]+).*class=\"odds\">([^<]+)`)
var str = `data-event-title="Yuichi Sugita* vs Adrian Mannarino">
<span class="odds-container">
<b class="odds">1/12</b>
</a>`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}