// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?s)data-event-title=\"([^*]+).*class=\"odds\">([^<]+)"#).unwrap();
let string = "data-event-title=\"Yuichi Sugita* vs Adrian Mannarino\">
<span class=\"odds-container\">
<b class=\"odds\">1/12</b>
</a>";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}