#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)url\(\.\.\/img\/(([\S]*?)\/)*"
Local $sString = "url(../img/repeat-elements/tpl-action-section_bg-1200.png) no-repeat 50%/1200px;" & @CRLF & _
"url(../img/pages/home/what-is_bg-1400.png) no-repeat 100% 50%/500px;" & @CRLF & _
"url(../img/blog/action/action_1-1400.png) no-repeat 100% 50%/500px;"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")