import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "url\\(\\.\\.\\/img\\/(([\\S]*?)\\/)*";
final String string = "url(../img/repeat-elements/tpl-action-section_bg-1200.png) no-repeat 50%/1200px;\n"
+ "url(../img/pages/home/what-is_bg-1400.png) no-repeat 100% 50%/500px;\n"
+ "url(../img/blog/action/action_1-1400.png) no-repeat 100% 50%/500px;";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}