// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)url\(\.\.\/img\/(([\S]*?)\/)*").unwrap();
let string = "url(../img/repeat-elements/tpl-action-section_bg-1200.png) no-repeat 50%/1200px;
url(../img/pages/home/what-is_bg-1400.png) no-repeat 100% 50%/500px;
url(../img/blog/action/action_1-1400.png) no-repeat 100% 50%/500px;";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}