using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"url\(\.\.\/img\/(([\S]*?)\/)*";
string input = @"url(../img/repeat-elements/tpl-action-section_bg-1200.png) no-repeat 50%/1200px;
url(../img/pages/home/what-is_bg-1400.png) no-repeat 100% 50%/500px;
url(../img/blog/action/action_1-1400.png) no-repeat 100% 50%/500px;";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}