$re = '/\b[+-]?\d+(?:,\d{3})*(?:\.\d+)?\b/';
$str = 'hello-sdvf-1,234.23 23 everybody 4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);