re = /\b[+-]?\d+(?:,\d{3})*(?:\.\d+)?\b/
str = 'hello-sdvf-1,234.23 23 everybody 4'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end