import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d{1,3}((\\.|\\,|\\s)\\d{3})*((\\.|\\,|\\s)\\d{1,3})?$";
final String string = "1,000,000.99\n\n"
+ "4 294 967 295,000\n\n"
+ "4 294 967.295,000\n\n"
+ "4.294.967.295,000\n\n"
+ "4,294,967,295.00\n\n"
+ "1\n\n"
+ "1.2\n\n"
+ "0.001\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}