// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\d{1,3}((\.|\,|\s)\d{3})*((\.|\,|\s)\d{1,3})?$").unwrap();
let string = "1,000,000.99
4 294 967 295,000
4 294 967.295,000
4.294.967.295,000
4,294,967,295.00
1
1.2
0.001
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}