$re = '/^\d{1,3}((\.|\,|\s)\d{3})*((\.|\,|\s)\d{1,3})?$/m';
$str = '1,000,000.99
4 294 967 295,000
4 294 967.295,000
4.294.967.295,000
4,294,967,295.00
1
1.2
0.001
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);