import re
regex = re.compile(r"^\d{1,3}((\.|\,|\s)\d{3})*((\.|\,|\s)\d{1,3})?$", flags=re.MULTILINE)
test_str = ("1,000,000.99\n\n"
"4 294 967 295,000\n\n"
"4 294 967.295,000\n\n"
"4.294.967.295,000\n\n"
"4,294,967,295.00\n\n"
"1\n\n"
"1.2\n\n"
"0.001\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")