using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"S(?<s>[0-9]+) ?\(([0-9]{1,})*\)";
string input = @"American Dad S01 (1).mkv
American Dad S05 (12).mkv";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}